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PEPPER GUIDE 3: 

CREATE, ENTER, AND EDIT A PEPFILE OR PROTOCOL 

Entering and Editing PepFiles and Protocols 

Creating a PepFile or Protocol 

A PepFile (*.pep) is a transcript of a speech sample that is entered in PEPPER and 
contains X, Y, and Z lines. A protocol is a special PepFile in which the Y and Z lines for 
each utterance are identical. Protocol files are typically created for transcripts of speech 
tasks that contain the same stimuli presented in a fixed sequence (e.g., articulation tests, 
MSAP repetition tasks). If you know that you will need to create many PepFiles for the 
same assessment task (for instance, a single-word imitation task administered to multiple 
speakers or administered to the same speaker multiple times), we suggest that you create 
a protocol file. Protocol files make keyboarding more efficient because the X lines are 
already entered in the desired order, and the Y and/or Z lines can be edited as needed to 
conform to a participant's phonetic output. 

PepFiles and protocols are created using the same procedure. When you first open 
PEPPER, you will see the File menu in the upper left-hand corner of the screen. Click on 
File (using a mouse) to get a list of menu selections, then choose “New” (again, using a 
mouse), then choose “PepFile Transcript & PVSP Log (.pep)” (using the mouse to 
highlight the selection if it is not already highlighted in the drop-down menu) and click on 
the “OK” button. A screen will appear, labeled PEPPER plus a number which corresponds 
to the number of the file created in the current entry session. The first PepFile created is 
labeled “PEPPER1", the second PepFile created is labeled “PEPPER2", etc. This label is 
replaced by a PepFile name when it is saved and named by the keyboarder. 

Entering a PepFile or Protocol 

When a new PepFile is opened, the cursor is automatically placed at the beginning of the 
X line of utterance 1. Above the X line is the utterance number in green, followed by a 
line. To begin entry, type the X line (the gloss, represented with orthographic symbols) of 
utterance 1. 

After you finish typing the X line, press Enter (or Return) to move to the Y line. The 
keyboard will now be set up according to the PEPPER Proportional font, represented by 
the white or right hand symbols on the PEPPER Keyboard Layout (Figure 1). Type the Y 
line, then press Enter. The Z line will automatically appear and be identical to the Y line. 
(NOTE: All instructions and suggestions for typing X, Y, and Z lines using the PEPPER 
Keyboard Layout begin on p. 10 with Figure 1 and continue to the end of this guide.)   
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If you are entering a protocol, you won't make any changes to the Z line. You simply press 
Enter to continue to the next utterance. If you are entering a PepFile from a speech 
sample that has been transcribed and the Z line transcription differs from the Y line (the 
intended form), edit the Z line as necessary, then press Enter to go to the next utterance. 
(The Y line may also require editing, especially if using PEPPER's "Automatically Fill Y 
Line" feature; see below.) Notice that on the screen the X line appears in black type, the 
Y line in blue type, and the Z line in red type. After pressing Enter in the Z line, the next 
utterance number, followed by a line, appears, and the cursor is placed at the beginning 
of the X line for the next utterance. 

For longer utterances that will not fit on one line on the screen or printout, it is not 
necessary to hit Return or Enter when the end of the line is reached. Continue to type 
and the program wraps around the text as necessary. This applies to X, Y, and Z lines. 
The program is also set up to automatically scroll down as the bottom of the screen is 
reached while typing. 

As mentioned earlier, a special optional feature available in the Edit menu automatically 
fills in the Y line based on the gloss entered in the X line. The program uses the most 
common transcription, the previous transcription (if the word occurred previously within 
the same PepFile), or spelling to fill in the Y line. This feature may be a time saver with 
some transcripts (if speech is normal) but not with others (if speech is delayed or unusual). 
Sometimes editing an automatically-filled Y line takes more time than entering the Y line 
manually. Your preference and skill dictate the use or nonuse of this feature during 
keyboarding. The feature is turned on and off by clicking on the Edit menu and selecting 
“Automatically Fill Y Line.” A checkmark in front of this selection indicates that the feature 
is activated. The feature can be activated and deactivated any time during entry. 

Another optional feature in the Edit menu allows for characters in the X, Y, and Z lines to 
be visually aligned on the screen (and printout), or, for a more compact look, not aligned, 
based on keyboarder preference. To activate or deactivate this feature, click on the Edit 
menu and select "Align XYZ." A checkmark in front of this selection indicates that the 
feature is activated. 

Error Checking a PepFile or Protocol 

The keyboarder should be familiar with the rules governing the formatting of X, Y, and Z 
lines and the use of symbols and diacritics (see PEPPER Guide 2). Some symbols (angle 
brackets, square brackets, parentheses, punctuation marks) are not allowed in the Y and 
Z lines. Other symbols, like the glottal stop (=), the synchronic tie (  + ) , and the underbar 

(-), should never be entered in the Y line. Finally, diacritic symbols that are always 

considered clinical distortion errors (e.g., dentalized ( I) or lateralized ( P) fricatives, 

derhotacized /rK/) should be entered in the Z line only. 

Some error checking in PEPPER is done “on line.” This means that the program is 
checking your entry as you’re entering. When a likely error is identified, such as a segment 

https://phonology.waisman.wisc.edu/wp-content/uploads/sites/532/2019/07/PEPPER-Guide-2.pdf
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correspondence mismatch between the Y and Z lines, an error message will come up on 
the screen indicating the nature of the error, and you will be required to correct it before 
you can move on to the next utterance.  

If a diacritic symbol is used to modify a main phonetic symbol in the Y line, a diacritic from 
the same set of symbols (e.g., nasal symbols, stop release symbols) must be used to 
modify the corresponding phonetic symbol in the Z line. If the main symbol and the 
diacritic symbol are the same in both the Y and Z lines, there is a Y-Z "match" and 
therefore no speech error. If the main symbol is the same in the Y and Z lines and the 
diacritic symbols are different but from the same set of symbols, there is a Y-Z "mismatch" 
and therefore a distortion error. When the main phonetic symbol is the same (i.e., there 
is not a substitution or deletion of the sound), an error message will be displayed if there 
is a diacritic symbol in the Y line but no diacritic symbol in the Z line, or if the diacritic 
symbol in the Z line differs from the corresponding diacritic symbol in the Y line and is 
from a different diacritic set. 

CAUTION: PEPPER does not catch all “illegal” (not conforming to PEPPER formatting or 
transcription guidelines) situations that may be encountered during entry. In particular, 
PEPPER accepts certain combinations of diacritics and phonemes that make no sense. 
Therefore, the keyboarder must be alert to possible errors in the transcript and consult 
with the transcriber if necessary. 

Editing a PepFile or Protocol 

Editing can be done any time during the entry process by using the mouse and/or other 
special keys described in Figure 1. Use the mouse, the scroll bar, and arrow keys to move 
around in the PepFile; use the backspace and delete keys to delete characters; use the 
home or end key to move to the start or end of a line, respectively. Use Ctrl with the arrow 
keys to move horizontally word-by-word or vertically utterance-by-utterance. 

Use “Go To…” on the Edit menu to move directly to a particular utterance number. Use 
the other six commands on the Edit menu to find or to find and replace text in the X, Y, or 
Z line. 

PEPPER provides a dictionary of possible alternative transcriptions for a particular word. 
If you want to edit a word in the Y line (which may be the case if you’re using the “Fill Y 
Line” feature), one option is to place the cursor on that word using the mouse and the left 
mouse button, and then press the right mouse button to display a list of alternative 
transcriptions of the word. Using the mouse and the left mouse button, the desired 
transcription of the word can be selected from the list, and the existing transcription of the 
word in the Y line will be replaced with the selected alternative. This feature may or may 
not be a time saver, depending on the degree to which a word must be edited. Another 
potentially quicker option is to delete, replace, and/or add characters as needed rather 
than to scan and select a particular alternative transcription of a word from a long list. 
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Whole utterances can be easily deleted and inserted. To delete an utterance, position the 
cursor anywhere in the X, Y, or Z line of the utterance, go to the Edit menu, and select 
“Delete Utterance.” The utterance will be deleted, and the remaining utterances will 
automatically be renumbered. To insert an utterance, position the cursor anywhere in the 
X, Y or Z line of the utterance following the place where the new utterance is to be 
inserted, go to the Edit menu, and select “Insert Utterance.” The new utterance will 
appear, and the cursor will appear at the beginning of the X line of the new, inserted 
utterance. You can then enter the X, Y, and Z lines as you would for any other utterance. 
As with “Delete Utterance,” other utterances within the PepFile will automatically be 
renumbered when an utterance is inserted. 

Saving a New PepFile or Protocol 

A PepFile or protocol can be saved at any time during entry. Go to the File menu and 
choose “Save.” The first time you save, a screen will appear wherein you can select the 
location to store the PepFile, name the PepFile or protocol, and select the type of file 
(indicated by an extension--in this case *.pep). Then click on the “Save” button. (Tip: We 
find it useful and efficient to save protocol files in their own separate location/folder.) The 
Save screen will disappear, and the specified PepFile name will replace the “PEPPER#” 
label in the upper left-hand corner of the screen. It is a good idea to save several times 
while entering a transcript, especially if it's a long one, to lessen the chances of losing 
large amounts of entered, unsaved information if the program unexpectedly shuts down. 
Once you’ve done an initial save wherein you’ve named the PepFile or protocol, 
subsequent saves will not bring up the initial Save screen described earlier. If you enter 
or edit utterances and do not save before attempting to close a PepFile or exit PEPPER, 
the program will prompt you with a message asking if you wish to save the PepFile or 
save the changes made to the PepFile since your last save.  

Note: If you are saving a new PepFile that has been created from an existing protocol, 
use "Save As..." rather than "Save," or your protocol file will be replaced with the new 
edited PepFile. See Using a Protocol to Create New PepFiles below. As a safeguard 
to prevent inadvertently replacing a protocol file, PEPPER will display the "Save As" 
screen when you select "Save" (or type Ctrl+S), and you will be prompted to save the 
new PepFile using a different name. 

Tips for Naming a PepFile or Protocol 

It is useful to develop a system for naming PepFiles and protocols. Note that Microsoft 
Windows rules and restrictions for file naming apply to PepFile names. Consider the 
following: 

 A simple numbering system can be used if entering more than one speech sample
for the same participant (e.g., 'JW1,' 'JW2,' 'JW3,' etc.) to easily identify each
sample by its PepFile name.
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 A coding scheme can be developed and incorporated into PepFile names for
different types of speech samples (conversational samples, articulation tests, etc.),
such as 'JW-CS1,' 'JW-AT1,' 'JW-AT2,' etc.

 A unique PepFile naming scheme can be used for protocol files, using a system
that identifies them by speech task and/or identifies them as protocols rather than
other types of PepFiles. (We have found that storing the protocol files in a separate
folder labeled "Protocols" adequately addresses this issue.)

NOTE: Incorporating identifying, personal, or sensitive participant information into a 
PepFile name is NOT recommended. 

PepFile Naming Requirements for MSAP Sources 

The Madison Speech Assessment Protocol (MSAP) includes speech tasks that are 
administered and audio and/or video recorded during an assessment session, and later 
glossed (if needed), phonetically transcribed, coded for prosody-voice (the conversational 
sample only), and/or acoustically analyzed. The resultant perceptual and acoustic data 
are used to assess a participant's segmental and suprasegmental speech output and to 
assign a speech classification (Speech Disorders Classification System [SDCS]). Each 
MSAP speech task, also called a source in PEPPER, may contribute to one or more 
PEPPER outputs (profiles, reports, analyses, indices). PEPPER identifies each source 
based on its PepFile name. Therefore, it is necessary to follow specific naming 
conventions for MSAP tasks, especially if acoustic analyses will be performed. 

The following table provides the PepFile naming conventions for the MSAP tasks that are 
entered and saved as PepFiles in PEPPER. The bolded portion of the PepFile name 
examples in the rightmost column represents how and where the string of characters must 
be present in the PepFile name, because PEPPER identifies the source based on that 
string. The characters can be upper or lower case. Any characters preceding or following 
the required string are for illustrative purposes only and can be modified as needed, with 
the guidelines from the previous section kept in mind. As some of the examples in the 
table demonstrate, characters following the required character string begin with an 
underbar ( _ ). 

Task/Source Abbreviation Required Characters Pepfile Name 
Example 

Conversational Sample CS -c# (where the # can
be 1, 2, 3, etc.)

abc2-c1.pep 

Goldman-Fristoe Test of 
Articulation-2 (Goldman & 
Fristoe, 2000) 

AT -GF 1234-gf.pep 

Lexical Stress Task LST -LST smile-LST_jd.pep 
Challenging Words Task CWT -CWT Spch-CWT.pep 
Vowel Task 1 VT1 -VT1 R2D2-vt1.pep 
Vowel Task 2 VT2 -VT2 HB2U-VT2.pep 
Vowel Task 3 VT3 -VT3 ElPre-VT3_1.pep 

https://phonology.waisman.wisc.edu/procedures-and-stimuli-for-speech-measures/
https://phonology.waisman.wisc.edu/
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Syllable Repetition Task SRT -SRT 2good-SRT.pep 
Nonword Repetition Task 
(Dollaghan & Campbell, 
1998) 

NRT -NRT CDTC-NRT.pep 

Emphatic Stress Task EST -EST Bob-EST.pep 
Rhotics and Sibilants 
Task 

RST -RST RandS-RST_glp.pep 

Multisyllabic Words Task 
1 (Catts, 1986) 

MWT1 -MWT1 child-MWT1.pep 

Multisyllabic Words Task 
2 (Catts, 1986) 

MWT2 -MWT2 Adult-MWT2.pep 

Speech Phrases Task 
(Catts, 1986) 

SPT -SPT 100KID-SPT_2a.pep 

Diadochokinesis Task DDK -DDK pataka-ddk.pep 
Sustained Vowel Task SVT -SVT aaaa-SVT.pep 
Sustained Consonant 
Task 

SCT -SCT FFFF-SCT.pep 

Printing a PepFile or Protocol 

The method used to print PepFiles and protocols is similar to that used in other Windows 
programs. Under the File menu, the “Print...” selection allows you to print the PepFile or 
protocol with the option of printing the whole document (selection “All”) or a page or range 
of pages (selection “Pages”). Note that if you wish to print one page only, specify that 
page number in both the “From” and “To” fields in the “Print” window. These fields should 
also be filled in if you wish to specify a range of pages. The number of copies you wish to 
print can also be specified. Click on the “OK” button to print once you’re satisfied with the 
printing conditions. 

Choosing “Print Preview” on the File menu allows you to see a whole page of a transcript 
as it will appear on your printout. You can zoom in or out as necessary, and you can print 
from this screen as well by clicking on the corresponding buttons that appear across the 
top of the screen. Choosing “Print Setup...” on the File menu allows you to specify a printer 
and the size and orientation (Portrait or Landscape) of your paper (Portrait orientation is 
preferable). 

If a color printer is used, colors as they appear on the screen appear on the printout. 
Otherwise, all type appears black on the printout. A heading across the top of each printed 
page includes the PepFile or protocol name, the date the PepFile was modified, the date 
the PepFile was printed, and finally the page number in the upper right hand corner.  

Closing a PepFile or Protocol 

To exit a PepFile or protocol, bring up the File menu and select “Close” or click on the “X” 
(gray "close" button) in the upper right hand corner of the PepFile screen. (Remember, if 
you’ve forgotten to save the file or any changes made to it since your last save, you’ll get 
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a prompt to save before PEPPER closes the file.) Closing a file will bring up a blank gray 
screen from which you can create a new file, open an existing file, or exit the PEPPER 
program. Choosing “Exit” in the File menu or clicking on the red "X" in the upper right 
hand corner of the program screen closes any open file(s), prompts you to save if you 
haven’t already done so, and then closes the PEPPER program. 

Opening an Existing PepFile or Protocol 

To open a previously created PepFile or protocol in PEPPER, go to the File menu and 
select “Open.” A screen appears wherein you can choose the location of the already 
created PepFile or protocol, the PepFile or protocol name, and the file type (*.pep). After 
choosing a directory and/or subdirectory, an alphabetical list of all the files of the specified 
type in that (sub)directory appears. To open the desired PepFile or protocol from the list, 
click twice on it with the left mouse button, click once on it with the left mouse button 
(which will bring up the name in the File Name field) and click the “Open” button that 
appears on the screen, or manually type the file name in the File Name field and click on 
the “Open” button. 

When you click on the File menu within a PEPPER session, a list of the four (or fewer) 
most recently accessed PepFiles appears above "Exit." If you wish to open one of the 
PepFiles listed, use the left mouse button to single-click on the file name, and it will come 
up on the screen.  

After opening a previously created PepFile or protocol using one of the methods 
described above, you can view or edit its contents. See special instructions next for 
updating/editing protocols and using protocols to create new PepFiles. 

Using a Protocol to Create New PepFiles 

To use a protocol file to create a new PepFile, open the protocol file and edit the Z lines 
and corresponding Y lines so that they match the transcript you are entering. Once all 
changes have been made, choose “Save As...” from the File menu and save the PepFile 
under a new name (and location if applicable). The original protocol file will remain 
unchanged, and the new PepFile will be created and saved. 

Editing or Updating a Previously Created Protocol 

To make changes to a protocol file, open it and edit it as needed. PEPPER will identify 
the file as being a protocol and, to safeguard against your inadvertently overwriting the 
protocol with an individual speaker’s results, will direct you to the "Save As" screen even 
if you choose "Save" or type Ctrl+S. Therefore, to change or update a protocol file, you 
must specify the same name it had before in the File name field in the "Save As" window, 
and then click "Yes" when asked to confirm that you want to replace it. 
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Exiting the PEPPER Program 

To exit the PEPPER program, choose “Exit” in the File menu, or use the left mouse button 
to click on the “X” (close button) that appears in the upper right hand corner of the program 
screen. 
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The PEPPER Keyboard Layout 

~  ~ !  o!  @  o@  #  o#  $  o$  %  o%  ^  ô   &  o&  *  o*  (  o(  )  o)  _  o_  +  + 

 `  ` 1  1  2  2  3  3  4  4  5  5  6  6  7  7  8  8  9  9  0  0  ‐  -  =  = 

Q  oQ  W  oW  E  oE  R  oR  T  oT  Y  oY  U  oU  I  oI  O  oO  P  oP  {  o{  }  o} 

q  q  w  w  e  e  r  r  t  t  y  y  u  u  i  i  o  o  p  p  [   [  ]   ] 

A  oA  S  oS  D  oD  F  oF  G  oG  H  oH  J  oJ  K  oK  L  oL  :  o:  "  o"  |  o| 

a  a  s  s  d  d  f  f  g  g  h  h  j  j  k  k  l  l  ;  ;  '  '  \  \ 

Z  oZ  X  oX  C  oC  V  oV  B  oB  N  oN  M  oM  <  < on >  > off  ?  o? 

z  z  x  x  c  c  v  v  b  b  n  n  m  m  ,  ,  .  .  /  / 

Figure 1. The PEPPER keyboard layout. 

Each key is divided into two areas. The symbols in the gray shaded areas are the labels on your keyboard (the upper symbol is the shifted 
key). These symbols (with some exceptions--see the next section) are typed in the X line; the shifted key is used to type capital letters, angle 
brackets, parentheses, question marks, and asterisks. (Note: The circle symbol (shift + \ key) in the white area can be typed in the X line.) 

The characters in the white corresponding areas are the locations of the PEPPER font symbols typed in the Y and Z lines. Where possible, 
the main PEPPER font symbols are arranged to correspond to English orthographic symbols. Most of the vowel and consonant orthographic 
symbols without English orthographic equivalents are located in the top and bottom rows, respectively. Diacritic symbols, seen in the upper 
white areas of the keyboard, are typed using the shifted keys. NOTE: The o character in the white upper area is used as a placeholder to 
show the position of each diacritic symbol relative to the main symbol. When the diacritic is typed, the o does not appear. 

Your keyboard may be laid out slightly differently than the keyboard shown above. Regardless of a character's location on your keyboard, 
the PEPPER font symbol displays and prints in the Y or Z line when you type the corresponding character shown in gray. Some keyboard 
variations are as follows: (1) the left-most key in the first row (~`) appears to the right of the third row, and (2) the right-most key in the third 
row (|\) appears to the right of the first or second row or to the left or right of the fourth row.
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Helpful Keyboarding Tips 

X Line Entry 

Not all symbols in the gray shaded areas in the PEPPER keyboard layout can be entered 
in the X line. Symbols that are allowed in the X line include 

 All 26 alphabet characters (lower case and shifted upper case) 
 Parentheses (used to enclose bound morphemes) 
 Square brackets (used to enclose comments) 
 Angle brackets (for disregarded words) 
 The forward slash '/ ' (for either/or words) 
 The punctuation symbols for comma (,), apostrophe ('), and question mark (?) 
 The asterisk (for unintelligible syllables and words) 

No other symbols in the gray shaded areas of the PEPPER keyboard can be entered in 
the X line. Punctuation marks other than the comma, apostrophe, and question 
mark cannot be entered in the X line. Numerals cannot be entered in the X line; they 
must be spelled and typed out using alphabetic symbols (four, thirtythree, one hundred, 
etc.). Hyphens cannot be entered in the X line and are therefore omitted when typing 
normally hyphenated words. 

One symbol in the white area of the PEPPER keyboard can be typed in the X line. The 
symbol for unsure, which is entered either by typing shift + \ to surround/circle an 
individual character or by typing F4 to surround/circle a word, can be typed in the X line. 
To "uncircle" a character or word, type shift + \ or F4, respectively. The backspace key 
can also be used to delete the unsure symbol. 

Diphthong Entry 

Diphthongs can be entered in the Y and Z lines with either one or two (first main vowel 
with overbar + second main vowel) keystrokes as follows  

Diphthong One Keystroke Two Keystrokes (white area on keyboard layout) 

e] F2 key type 'e' key, then ' ] ' key 

e[ F3 key type 'e' key, then ' [ ' key 

3] F7 key type '3' key, then ' ] ' key 

o[ F8 key type 'o' key, then ' [ ' key 

9] F9 key type '9' key, then ' ] ' key 
  
Onglides and Offglides 

Any phonetic symbol can be entered as an onglide or offglide (also known as an intrusive 
sound or sound addition) to a main phonetic symbol in the Y and Z lines. If an intrusive 



12 

(either an onglide or offglide) occurs between two phonemes and you are unsure whether 
to type it as an offglide to the first phoneme or an onglide to the second phoneme, "attach 
it to" the phoneme which it most likely modifies (possibly the more difficult sound to 
articulate) and/or with the phoneme with which it shares the most sound characteristics 
(taking into account whether the intrusive sound is a vowel or consonant; and its place, 
manner, and voicing features). To enter an intrusive 

 Enter an onglide by typing the '<' (shift ,) key, followed by the intrusive phoneme
symbol before typing the main phoneme symbol

 Enter an offglide by typing the '>' (shift .) key, followed by the intrusive phoneme
symbol after typing the main phoneme symbol

Note that diacritic symbols cannot be affixed to onglides and offglides. 

Description of Keyboard Usage 

The following reference table, also available for viewing in the Help section of PEPPER 
(see "PEPPER Keyboard Layout" in Contents or Index), augments the information 
provided above. It includes a description of each character used in PepFile entry. The 
entries in this reference table are sequenced as follows: (1) the special function keys are 
described; (2) characters used only in the X line are described; (3) characters used in two 
or more lines are described; and (4) characters used only in the Z line are described. 
While going through this table, you may find it useful to locate each character on the 
keyboard layout on p. 10.  

Character Purpose, 
Symbol(s), 
Description 

Line(s) in 
Which 

Permitted 

Description/How to Enter 

Special Keys 
Backspace To delete 

characters 
X, Y, Z The backspace key functions as usual to delete 

typed characters preceding the cursor. 
Shift To capitalize or 

enter punctuation 
symbols or '*' in 
X; for diacritics in 
Y/Z 

X, Y, Z Hold down one of the two SHIFT keys and type 
another key to produce the corresponding capital 
letter, asterisk, or punctuation symbol in the X line; 
and to type the corresponding diacritic in the Y/Z 
line(s) 

F4 To circle words in 
X or Z line 

X, Z After the last character in a word, press the F4 key 
to circle the entire word (or to uncircle the word if it 
is already circled). 

Space To insert spaces 
between words 

X, Y, Z PEPPER requires one space between words and 
ignores any additional spaces between words. 

Delete To delete the 
character after 
the cursor 

X, Y, Z Press the Delete key to erase a character following 
the cursor. Successive presses erase all entries in 
the reverse order in which they were entered; 
therefore, where indicated in this table, the correct 
sequence of character entries must be followed. 

Orthographic/Phonetic Keys 
English 
Alphabet 

a-z (lower case
and upper case
capitals)

X only In the X line, press one of the alphabet keys to get 
the corresponding letter. Type SHIFT + the 
alphabet key for a capital letter. Separate all words 
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with one space. Press ENTER to move from the X 
line to the Y line. 

Punctuation ,  '  ? X only The unshifted comma (,) and apostrophe (') keys 
are used to enter commas and apostrophes in the 
X line; the question mark is entered by typing 
SHIFT + the / key. No other punctuation marks are 
available for entry in the X line. 

Parentheses (  ) X only Parentheses, used to enclose bound morphemes, 
are entered by pressing SHIFT plus the left or right 
parenthesis key. 

Comments [  ] X only Unshifted square brackets, used to enclose 
comments, may be entered anywhere in the X line. 
Comments, which may be abbreviated, are used 
for descriptive purposes only and do not affect 
PEPPER outputs. See PEPPER Help for additional 
information, including how to get a Comments 
Summary. 

Disregard <  > X only The Disregard characters (angle brackets), plus 
the following 3 characters in this table, belong to a 
set of "questionable words" symbols that are used 
to exclude sounds, part words, or words in a 
PepFile from certain quantitative analyses. See pp. 
26-29 in PG2 for rules for the use of Disregards. 

Press SHIFT and the left and right angle brackets 
to enclose sounds, syllables, and words in the X 
line that should be disregarded in PEPPER 
outputs. Observe appropriate spacing and enter 
corresponding transcription entries (without angle 
brackets) in the Y and Z lines. 

Either/Or 
/ 

X only An Either/Or symbol (unshifted forward slash) 
separates two likely glosses for a word, with the 
first word being the more likely, given context and 
known speaker variables (i.e., him/he, want/went). 
In the Y and Z lines, the corresponding entry is 
based on the first of the two words. See p. 29 in 
PG2 for rules for the use of Either/Ors. 

Unsure 
| 

X, Z The Unsure symbol (which represents circling 
although it appears rectangular in PEPPER) is 
used to enclose any segment where the gloss (X 
line) or transcription (Z line) is in doubt, and is 
entered by pressing SHIFT + \ after each 
questionable segment. (The F4 key, as previously 
described, can be used to circle or uncircle a whole 
word.) 

When entering the Unsure symbol in the Z line, 
follow this typing sequence: (1) enter the main 
character, (2) enter any associated diacritics, and 
(3) enter the Unsure (box) symbol. See pp. 29-30 
in PG2 for rules for the use of Unsures. 

Unintelligilble * X, Y, Z The Unintelligible symbol (i.e., the symbol of last 
resort) is used for each syllable in the X line that 
cannot be glossed and for syllables in the Y and Z 
lines that cannot be transcribed. A multisyllabic 
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word is represented by adjacent asterisks (e.g. an 
unintelligible two-syllable word is entered **), with 
spaces between symbols to indicate different 
words. See pp.30-32 in PG2 for rules for the use of 
Unintelligibles. 

To enter an Unintelligible symbol in the X line, type 
SHIFT + 8. To enter an Unintelligible symbol in the 
Y and Z lines, type the unshifted \ key. 

Phonetic 
Alphabet 

All vowels, 
diphthongs, and 

consonants 

Y, Z In PEPPER, the keyboard switches from the 
English alphabet to a phonetic alphabet when 
ENTER is pressed to move from the X line to the Y 
line and remains in the latter mode for the Z line. 
The available phonetic characters for vowels and 
consonants are located in the white areas in the 
keyboard layout on p. 9. The glottal stop symbol [=] 
can be entered as a main character or 
onglide/offglide only in the Z line.  

Diacritics All diacritics 
except those 
noted below 

Y, Z All diacritic characters except onglides are entered 
after the main character has been entered by 
pressing and holding the SHIFT key, followed by 
the desired diacritic key(s). Onglides are typed 
before the main character is entered. PEPPER 
positions all diacritic symbols appropriately relative 
to the main character and to other diacritics. 

Juncture 
Symbols 

E R T Y U Y, Z Juncture symbols, used for descriptive purposes 
only, are typically entered only in the Z line, 
although they can be entered in the Y line too. 
PEPPER stores and reproduces them on some 
analyses outputs, but they are never included in 
analyses for Y-Z correspondence or for 
phonetic/phonologic correctness. (See p. 40 in 
PG2). 

To enter a juncture symbol, first enter the main 
character and then the desired juncture symbol. 
Only one juncture symbol per main character is 
allowed and should be followed by a space if 
followed by another word.   

Stress 
Symbols  B N M 

Y, Z Stress symbols, used to describe syllable or word 
stress, are typically entered only in the Z line, 
although they can be entered in the Y line too. 
PEPPER stores and reproduces them on some 
analyses outputs, but they are never included in 
analyses for Y-Z correspondence or for 
phonetic/phonologic correctness. (See p. 40 in 
PG2). 

To enter a stress symbol, first enter the main vowel 
or syllabic consonant and then the desired stress 
symbol. Note that only one stress symbol per main 
character is allowed and that a stress symbol 
should not be entered on a non-syllabic consonant. 
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Syllabic 
Consonants 

[  ? ] Y, Z PEPPER requires that there is at least one vowel 
or syllabic consonant present in each non-
questionable word in a PepFile and displays an 
error message if there is not. 

To enter the syllabic diacritic, first enter the symbol 
for the consonant, then hold down the SHIFT key 
and type the / key. 

Onglides and 
Offglides 

Any phonetic 
character--

vowels, 
diphthongs, 
consonants 

Y, Z Onglides and offglides, entered before and after a 
main character, respectively, are also called 
intrusives or sound additions. Onglides or offglides 
should be entered so that they are "attached" to 
the correct main character (see guidelines on pp. 
10-11) because computations in the PEPPER 
analyses will follow the way the intrusive sounds 
were entered. (p. 43 in PG2).

To enter an onglide, (1) type SHIFT <, (2) enter the 
phonetic symbol for the onglide, and (3) enter the 
main character. To enter an offglide, (1) enter the 
main character, (2) type SHIFT >, and (3) enter the 
phonetic symbol for the offglide. Note that diacritics 
cannot be affixed to onglides or offglides, and 
entering a diphthong as an onglide or offglide, 
while possible, is discouraged. 

Tied Sounds 
+ 

Z only The tied diacritic (synchronic tie), available in the Z 
line only, is used to represent phoneme additions 
while maintaining PEPPER's mandatory 1:1 
segmental correspondence between the Y and Z 
lines. For example, if a child says "hair" for "air," 
the /h/ can be attached like this: [h+2r]. Tied 

phonemes are treated as substitutions in PEPPER 
analyses; any associated diacritics are ignored in 
quantitative analyses. (pp. 44-45 in PG2). 

To enter a synchronic tie symbol, (1) enter the first 
main phonetic character, (2) hold down the SHIFT 
key and type the = key, and (3) enter the second 
main phonetic character. All diacritic symbols other 
than the onglide symbol must be entered after the 
second main phonetic character. Diacritic symbols 
cannot be attached individually to one of the two 
tied sounds; any diacritics are interpreted as 
belonging to both of the tied segments, and any 
diacritic symbols above or below the tied sounds 
will appear centered between the two. 

Missing 
Segments 

- Z only Missing segments (i.e., sound omissions or 
deletions) in the Z line are indicated by the 
underbar symbol in order to maintain segmental 
correspondence between the Y and Z lines (pp. 
56-60 in PG2). To enter the underbar symbol (in 
the Z line only), press the '-' key. 
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